summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 16:44:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:25 +0300
commitdd331f491db93d2854c591bd4f9160b565671408 (patch)
tree50deebd79d41a9f1f30066306fa3389cd79dc8de /gnu/packages/julia-xyz.scm
parentc1f7692fcac793603e0e15c99e8530c015eda302 (diff)
downloadguix-patches-dd331f491db93d2854c591bd4f9160b565671408.tar
guix-patches-dd331f491db93d2854c591bd4f9160b565671408.tar.gz
gnu: Add julia-parameters.
* gnu/packages/julia-xyz.scm (julia-parameters): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 72a60ad6d7..4a4be83889 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1331,6 +1331,31 @@ originating @code{build_tarballs.jl} script can be found on the community
build tree Yggdrasil.")
(license license:expat))))
+(define-public julia-parameters
+ (package
+ (name "julia-parameters")
+ (version "0.12.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mauro3/Parameters.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b8lawi7kcws4axfsdf023gyxca15irl648ciyi1kw3wghz3pfi2"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-orderedcollections" ,julia-orderedcollections)
+ ("julia-unpack" ,julia-unpack)))
+ (home-page "https://github.com/mauro3/Parameters.jl")
+ (synopsis "Numerical-model parameter helpers")
+ (description "This package contains types with default field values, keyword
+constructors and (un-)pack macros. Keyword functions can be slow in Julia,
+however, the normal positional constructor is also provided and could be used in
+performance critical code.")
+ (license license:expat)))
+
(define-public julia-parsers
(package
(name "julia-parsers")