summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-31 10:25:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:54:45 +0300
commitccbf9c450e50a31081d2865aba700e823c21ef35 (patch)
treea324808c87d769aa631c76f871fc88745fef3611 /gnu/packages/julia-xyz.scm
parentc85edf2ca47a10634faba15848cca7b4558a82ab (diff)
downloadguix-patches-ccbf9c450e50a31081d2865aba700e823c21ef35.tar
guix-patches-ccbf9c450e50a31081d2865aba700e823c21ef35.tar.gz
gnu: Add julia-dataapi.
* gnu/packages/julia-xyz.scm (julia-dataapi): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 66289a78a7..dd8e2390c8 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -440,6 +440,29 @@ both the 256 color and 24 bit true color extensions, and the different text
styles available to terminals.")
(license license:expat)))
+(define-public julia-dataapi
+ (package
+ (name "julia-dataapi")
+ (version "1.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaData/DataAPI.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14sfvkz169zcbap3gdwpj16qsap783h86fd07flfxk822abam11w"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaData/DataAPI.jl")
+ (synopsis "Data-focused namespace for packages to share functions")
+ (description "This package provides a namespace for data-related generic
+function definitions to solve the optional dependency problem; packages wishing
+to share and/or extend functions can avoid depending directly on each other by
+moving the function definition to DataAPI.jl and each package taking a
+dependency on it.")
+ (license license:expat)))
+
(define-public julia-datastructures
(package
(name "julia-datastructures")