summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-25 02:05:01 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-29 16:47:20 +0200
commitbb1ca1f372025e9e28513ae831c6e239404860a8 (patch)
treed52ac63d75d0128f30b7257a78e901dabd6aa9dd /gnu/packages/julia-xyz.scm
parent658fca53e9dd04727144f1e7b30b77d1a1481f4f (diff)
downloadguix-patches-bb1ca1f372025e9e28513ae831c6e239404860a8.tar
guix-patches-bb1ca1f372025e9e28513ae831c6e239404860a8.tar.gz
gnu: Add julia-chainrulescore.
* gnu/packages/julia-xyz.scm (julia-chainrulescore): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 8e95c8b7ed..0da2452b89 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -121,6 +121,31 @@ operations. It can wrap any @code{IO} type automatically making incremental
reading and writing faster.")
(license license:expat)))
+(define-public julia-chainrulescore
+ (package
+ (name "julia-chainrulescore")
+ (version "0.9.29")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaDiff/ChainRulesCore.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1k0iayw39n1ikkkhvyi4498vsnzc94skqs41gnd15632gxjfvki4"))))
+ (build-system julia-build-system)
+ (inputs ;required for tests
+ `(("julia-benchmarktools" ,julia-benchmarktools)
+ ("julia-staticarrays" ,julia-staticarrays)))
+ (propagated-inputs
+ `(("julia-compat" ,julia-compat)))
+ (home-page "https://github.com/JuliaDiff/ChainRulesCore.jl")
+ (synopsis "Common utilities used by downstream automatic differentiation tools")
+ (description "The package provides a light-weight dependency for defining
+sensitivities for functions without the need to depend on ChainRules itself.")
+ (license license:expat)))
+
(define-public julia-colors
(package
(name "julia-colors")