summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-23 20:46:41 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-29 16:47:21 +0200
commitb91ad8324dec459181cb664863a36fd6616a63eb (patch)
tree28760d0dde4351693b2012753bf9d6d716dd9e18 /gnu/packages/julia-xyz.scm
parent2ca38ee4e70cdbd26a1faa719e1a4ec8ef6476e3 (diff)
downloadguix-patches-b91ad8324dec459181cb664863a36fd6616a63eb.tar
guix-patches-b91ad8324dec459181cb664863a36fd6616a63eb.tar.gz
gnu: Add julia-calculus.
* gnu/packages/julia-xyz.scm (julia-calculus): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index c5c04d6579..75b46a1c7c 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -121,6 +121,30 @@ operations. It can wrap any @code{IO} type automatically making incremental
reading and writing faster.")
(license license:expat)))
+(define-public julia-calculus
+ (package
+ (name "julia-calculus")
+ (version "0.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaMath/Calculus.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xh0ak2ycsjw2h86ja24ch3kn2d18zx3frrds78aimwdnqb1gdc2"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaMath/Calculus.jl")
+ (synopsis "Common utilities for automatic differentiation")
+ (description "This package provides tools for working with the basic
+calculus operations of differentiation and integration. The @code{Calculus}
+package produces approximate derivatives by several forms of finite
+differencing or produces exact derivative using symbolic differentiation. It
+can also be used to compute definite integrals by different numerical
+methods.")
+ (license license:expat)))
+
(define-public julia-chainrulescore
(package
(name "julia-chainrulescore")