summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-08 15:43:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:57:24 +0300
commit9949289082c7c4f6c7430bc01add5145b64f4ba8 (patch)
treefff66d6e53d68ecbefa61aa8dc60ff29ccf0a799 /gnu/packages/julia-xyz.scm
parentba637c5cb200f3c81f7685e08c5cc711d5b6eef3 (diff)
downloadguix-patches-9949289082c7c4f6c7430bc01add5145b64f4ba8.tar
guix-patches-9949289082c7c4f6c7430bc01add5145b64f4ba8.tar.gz
gnu: Add julia-paddedviews.
* gnu/packages/julia-xyz.scm (julia-paddedviews): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 0471a8d8f9..2a58c0c780 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1615,6 +1615,33 @@ have arbitrary indices, similar to those found in some other programming
languages like Fortran.")
(license license:expat)))
+(define-public julia-paddedviews
+ (package
+ (name "julia-paddedviews")
+ (version "0.5.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaArrays/PaddedViews.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ran2vj6ahlzib0g77y7g0jhavy3k9s2mqq23ybpgp9z677wf26h"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f)) ;require Documenter, not packaged yet
+ (propagated-inputs
+ `(("julia-offsetarrays" ,julia-offsetarrays)))
+ (home-page "https://github.com/JuliaArrays/PaddedViews.jl")
+ (synopsis "Add virtual padding to the edges of an array")
+ (description "@code{PaddedViews} provides a simple wrapper type,
+@code{PaddedView}, to add \"virtual\" padding to any array without copying data.
+Edge values not specified by the array are assigned a @code{fillvalue}.
+Multiple arrays may be \"promoted\" to have common indices using the
+@code{paddedviews} function.")
+ (license license:expat)))
+
(define-public julia-parameters
(package
(name "julia-parameters")