summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-08 13:11:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:57:24 +0300
commit8735dc17d0d86ebdd5a6987f6c68ff1a9985fcc0 (patch)
tree9b49131153cecfaa5933216df5df4e9c376fab1f /gnu/packages/julia-xyz.scm
parent495df0b0c600c70c44903efb6a08cf007f0d8ee8 (diff)
downloadguix-patches-8735dc17d0d86ebdd5a6987f6c68ff1a9985fcc0.tar
guix-patches-8735dc17d0d86ebdd5a6987f6c68ff1a9985fcc0.tar.gz
gnu: Add julia-logexpfunctions.
* gnu/packages/julia-xyz.scm (julia-logexpfunctions): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 0718463b33..591085d110 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1235,6 +1235,32 @@ extensions to the iterator interface.")
and printing JSON documents.")
(license license:expat)))
+(define-public julia-logexpfunctions
+ (package
+ (name "julia-logexpfunctions")
+ (version "0.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaStats/LogExpFunctions.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rvms3mmq8a1viqlyzdgs2ccddcy6j0c677dlb8m5nk6hkiwr16n"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-docstringextensions" ,julia-docstringextensions)))
+ (native-inputs
+ `(("julia-offsetarrays" ,julia-offsetarrays)))
+ (home-page "https://github.com/JuliaStats/LogExpFunctions.jl")
+ (synopsis "Special functions based on @code{log} and @code{exp}")
+ (description "Various special functions based on log and exp moved from
+@code{StatsFuns.jl} into a separate package, to minimize dependencies. These
+functions only use native Julia code, so there is no need to depend on
+@code{librmath} or similar libraries.")
+ (license license:expat)))
+
(define-public julia-macrotools
(package
(name "julia-macrotools")