summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-14 12:57:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-14 14:45:22 +0300
commit6eb1b1d8790fc7d0f1d169aa702d2c0b0f759aaa (patch)
tree0b67ea6221d4535a454e59d04031e874b2dda579 /gnu/packages/julia-xyz.scm
parent57860112ce3bb53cff1854f40b7e13875f242551 (diff)
downloadguix-patches-6eb1b1d8790fc7d0f1d169aa702d2c0b0f759aaa.tar
guix-patches-6eb1b1d8790fc7d0f1d169aa702d2c0b0f759aaa.tar.gz
gnu: Add julia-imagemetadata.
* gnu/packages/julia-xyz.scm (julia-imagemetadata): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index e7fc415807..0743cda3b0 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1671,6 +1671,38 @@ such arrays easy via traits.")
of packages designed to support image processing and computer vision.")
(license license:expat)))
+(define-public julia-imagemetadata
+ (package
+ (name "julia-imagemetadata")
+ (version "0.9.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaImages/ImageMetadata.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0iv154ms370xgcr56bwsjl13iwmy671cbxjl9ld5yfj85pclcwi1"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-axisarrays" ,julia-axisarrays)
+ ("julia-imageaxes" ,julia-imageaxes)
+ ("julia-imagecore" ,julia-imagecore)
+ ("julia-indirectarrays" ,julia-indirectarrays)))
+ (native-inputs
+ `(("julia-offsetarrays" ,julia-offsetarrays)
+ ("julia-simpletraits" ,julia-simpletraits)
+ ("julia-unitful" ,julia-unitful)))
+ (home-page "https://github.com/JuliaImages/ImageMetadata.jl")
+ (synopsis "Julia package for images having metadata")
+ (description "@code{ImageMetadata} is a simple package providing utilities
+for working with images that have metadata attached. For example, you might
+want to associate an image with the date on which the picture was taken, or an
+MRI scan with patient data, or an astronomical image with sky coordinates and
+information about the detector used to acquire the image.")
+ (license license:expat)))
+
(define-public julia-indexing
(package
(name "julia-indexing")