summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:07:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:54:47 +0300
commit6a2d36c734a5c5ab7e1826ce9372f680c0fe772d (patch)
tree3c9471bdb8c05c94cac769364c9e0168499e72e3 /gnu/packages/julia-xyz.scm
parent277fef2026024c90518e0eff12a06b9593782f40 (diff)
downloadguix-patches-6a2d36c734a5c5ab7e1826ce9372f680c0fe772d.tar
guix-patches-6a2d36c734a5c5ab7e1826ce9372f680c0fe772d.tar.gz
gnu: Add julia-tensorcore.
* gnu/packages/julia-xyz.scm (julia-tensorcore): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 33f597ca3f..c802c2b0c5 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2023,6 +2023,29 @@ participate in the @code{TableTraits.jl} ecosystem.")
(description "TableTraits defines a generic interface for tabular data.")
(license license:expat)))
+(define-public julia-tensorcore
+ (package
+ (name "julia-tensorcore")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaMath/TensorCore.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sy3in4a1rl3l2vk0cm9mzg2nkva7syhr7i35si0kbzhkdwpbqjy"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaMath/TensorCore.jl")
+ (synopsis "Tensor-algebra definitions")
+ (description "This package is intended as a lightweight foundation for
+tensor operations across the Julia ecosystem. Currently it exports three
+operations: @acronym{hadamard, elementwise multiplication}, @acronym{tensor,
+product preserves all dimensions}, and @acronym{boxdot, contracts neighboring
+dimensions}.")
+ (license license:expat)))
+
(define-public julia-unpack
(package
(name "julia-unpack")