summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-25 02:04:57 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-29 16:47:19 +0200
commit651a55738973c36524c05b3e65b02bccfc352743 (patch)
tree72abcd52f334a269c31f789f5cf4ab566b359293 /gnu/packages/julia-xyz.scm
parenta8e3be6aa124151420282d2576af916a89a1b23f (diff)
downloadguix-patches-651a55738973c36524c05b3e65b02bccfc352743.tar
guix-patches-651a55738973c36524c05b3e65b02bccfc352743.tar.gz
gnu: Add julia-abstractffts.
* gnu/packages/julia-xyz.scm (julia-abstractffts): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 7a3529fe8f..4abeaa765f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -24,6 +24,31 @@
#:use-module (guix build-system julia)
#:use-module (gnu packages tls))
+(define-public julia-abstractffts
+ (package
+ (name "julia-abstractffts")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaMath/AbstractFFTS.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0083pwdyxjb04i330ir9pc8kmp4bwk59lx1jgc9qi05y8j7xzbp0"))))
+ (build-system julia-build-system)
+ (inputs ;required for tests
+ `(("julia-unitful" ,julia-unitful)))
+ (home-page "https://github.com/JuliaGPU/Adapt.jl")
+ (synopsis "General framework for fast Fourier transforms (FFTs)")
+ (description "This package allows multiple FFT packages to co-exist with
+the same underlying @code{fft(x)} and @code{plan_fft(x)} interface. It is
+mainly not intended to be used directly. Instead, developers of packages that
+implement FFTs (such as @code{FFTW.jl} or @code{FastTransforms.jl}) extend the
+types/functions defined in AbstractFFTs.")
+ (license license:expat)))
+
(define-public julia-adapt
(package
(name "julia-adapt")