summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-08 16:28:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:57:25 +0300
commit5be9b3fd6b23b1e0cb62d8f93e01c97265cfe0da (patch)
treea83778a130c9224ab606cf11f3c525da3041f2d4 /gnu/packages/julia-xyz.scm
parent48b9f37a73c564827036eeac9142667c33eb8d5b (diff)
downloadguix-patches-5be9b3fd6b23b1e0cb62d8f93e01c97265cfe0da.tar
guix-patches-5be9b3fd6b23b1e0cb62d8f93e01c97265cfe0da.tar.gz
gnu: Add julia-nnlib.
* gnu/packages/julia-xyz.scm (julia-nnlib): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 68a56b3844..5804619c25 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1636,6 +1636,43 @@ still being completely generic
@code{NaN} instead of throwing a @code{DomainError}.")
(license license:expat)))
+(define-public julia-nnlib
+ (package
+ (name "julia-nnlib")
+ (version "0.7.19")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FluxML/NNlib.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "163v7hkmbxxgnq7qigmqjdqcdywi2njxbh54w8v0hf4bddnalbba"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'drop-cuda-support
+ (lambda _
+ (substitute* "test/runtests.jl"
+ (("using CUDA") ""))
+ (setenv "NNLIB_TEST_CUDA" "false"))))))
+ (propagated-inputs
+ `(("julia-adapt" ,julia-adapt)
+ ("julia-chainrulescore" ,julia-chainrulescore)
+ ("julia-requires" ,julia-requires)))
+ (native-inputs
+ `(("julia-chainrulestestutils" ,julia-chainrulestestutils)
+ ("julia-stablerngs" ,julia-stablerngs)
+ ("julia-zygote" ,julia-zygote)))
+ (home-page "https://github.com/FluxML/NNlib.jl")
+ (synopsis "Neural Network primitives with multiple backends")
+ (description "This package will provide a library of functions useful for
+machine learning, such as softmax, sigmoid, convolutions and pooling. It
+doesn't provide any other \"high-level\" functionality like layers or AD.")
+ (license license:expat)))
+
(define-public julia-optimtestproblems
(package
(name "julia-optimtestproblems")