summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-10-14 17:59:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-10-19 10:22:11 +0300
commit4b7b94cac86e08a063cf4a8919912ca9f025a6b6 (patch)
tree5238d840f6db88702a6bdc7acb1d83f579e412a9 /gnu/packages/julia-xyz.scm
parente6cda550e2cab3d9210f2ba46220d50d6d8f922a (diff)
downloadguix-patches-4b7b94cac86e08a063cf4a8919912ca9f025a6b6.tar
guix-patches-4b7b94cac86e08a063cf4a8919912ca9f025a6b6.tar.gz
gnu: Add julia-functors.
* gnu/packages/julia-xyz.scm (julia-functors): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 9604460600..a1f3cc4cfb 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1743,6 +1743,31 @@ differentiation (AD).")
arbitrary functions.")
(license license:expat)))
+(define-public julia-functors
+ (package
+ (name "julia-functors")
+ (version "0.2.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FluxML/Functors.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03ry1wn1y2jssq65l29bi6q4ki041aa6gl1nd2w6cgl00k2mrxf3"))))
+ (build-system julia-build-system)
+ (home-page "https://fluxml.ai/Functors.jl/stable/")
+ (synopsis "Design pattern for structures as in machine learning")
+ (description "This package provides tools to express a design pattern for
+dealing with large/ nested structures, as in machine learning and
+optimisation. For large machine learning models it can be cumbersome or
+inefficient to work with parameters as one big, flat vector, and structs help
+in managing complexity; but it is also desirable to easily operate over all
+parameters at once, e.g. for changing precision or applying an optimiser
+update step.")
+ (license license:expat)))
+
(define-public julia-fuzzycompletions
(package
(name "julia-fuzzycompletions")