summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:36:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:49 +0300
commit4a1d456a99948b75be078146b44b6e89880b9bc4 (patch)
tree60b5d3938508f7b396e92c7091dc9d2a7c59b2d4 /gnu/packages/julia-xyz.scm
parentfda20c75216c8459165107460b8ed6cc7cb5f292 (diff)
downloadguix-patches-4a1d456a99948b75be078146b44b6e89880b9bc4.tar
guix-patches-4a1d456a99948b75be078146b44b6e89880b9bc4.tar.gz
gnu: julia-zstd-jll: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-zstd-jll): Move to ... * gnu/packages/julia-jll.scm: ... here.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm40
1 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 3eabf7a5ad..3b73b4352b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -23,7 +23,6 @@
#:use-module (guix packages)
#:use-module (guix git-download)
#:use-module (guix build-system julia)
- #:use-module (gnu packages compression)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages julia-jll))
@@ -1772,45 +1771,6 @@ useful in order to support @code{VersionNumber} comparisons applied to
archives in Julia.")
(license license:expat)))
-(define-public julia-zstd-jll
- (package
- (name "julia-zstd-jll")
- (version "1.5.0+0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaBinaryWrappers/Zstd_jll.jl")
- (commit (string-append "Zstd-v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "15g5wsvga4p9bjmx97xqwqdnfzfbwfl6c4a9iaphcncwgcrnw6y6"))))
- (build-system julia-build-system)
- (arguments
- '(#:tests? #f ; no runtests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
- (lambda* (#:key inputs #:allow-other-keys)
- (map
- (lambda (wrapper)
- (substitute* wrapper
- (("generate_wrapper_header.*")
- (string-append
- "generate_wrapper_header(\"Zstd\", \""
- (assoc-ref inputs "zstd:lib") "\")\n"))))
- ;; There's a Julia file for each platform, override them all
- (find-files "src/wrappers/" "\\.jl$")))))))
- (inputs
- `(("zstd:lib" ,zstd "lib")))
- (propagated-inputs
- `(("julia-jllwrappers" ,julia-jllwrappers)))
- (home-page "https://github.com/JuliaBinaryWrappers/Zstd_jll.jl")
- (synopsis "Zstd library wrappers")
- (description "This package provides a wrapper for the zstd library.")
- (license license:expat)))
-
(define-public julia-zygoterules
(package
(name "julia-zygoterules")