summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-25 02:04:51 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-29 16:47:18 +0200
commit45debc7b855a97604d73da2dbf1b65bb5a080955 (patch)
tree761cf2d7ee3478623b30e3ce98a8e9253b3609dc /gnu/packages/julia-xyz.scm
parent35044d3e3ef183fd3b6986e3a86d6c7a1c8164a4 (diff)
downloadguix-patches-45debc7b855a97604d73da2dbf1b65bb5a080955.tar
guix-patches-45debc7b855a97604d73da2dbf1b65bb5a080955.tar.gz
gnu: Add julia-macrotools.
* gnu/packages/julia-xyz.scm (julia-macrotools): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 7fbb18347f..5ba85f8bc0 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -344,6 +344,27 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
and printing JSON documents.")
(license license:expat)))
+(define-public julia-macrotools
+ (package
+ (name "julia-macrotools")
+ (version "0.5.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FluxML/MacroTools.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0k4z2hyasd9cwxf4l61zk3w4ajs44k69wx6z1ghdn8f5p8xy217f"))))
+ (build-system julia-build-system)
+ (home-page "https://fluxml.ai/MacroTools.jl")
+ (synopsis "Tools for working with Julia code and expressions")
+ (description "This library provides tools for working with Julia code and
+expressions. This includes a template-matching system and code-walking tools
+that let you do deep transformations of code.")
+ (license license:expat)))
+
(define-public julia-mbedtls
(package
(name "julia-mbedtls")