summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-07-06 20:06:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-07-11 13:03:32 +0300
commit373a625bd065463ee23dd1f4a4042677f3cebae8 (patch)
treeae1ad4ce87372835a6820a5457a99bd842bb061e /gnu/packages/julia-xyz.scm
parentc9ceb301c696c0c032ce6ee3a2c5f57ca78b0fc4 (diff)
downloadguix-patches-373a625bd065463ee23dd1f4a4042677f3cebae8.tar
guix-patches-373a625bd065463ee23dd1f4a4042677f3cebae8.tar.gz
gnu: Add julia-sentinelarrays.
* gnu/packages/julia-xyz.scm (julia-sentinelarrays): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 7491ee3f5d..c53efb3d76 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4797,6 +4797,27 @@ user-friendly, scratch spaces should, in general, not be used for a storing
files that the user must interact with through a file browser.")
(license license:expat)))
+(define-public julia-sentinelarrays
+ (package
+ (name "julia-sentinelarrays")
+ (version "1.3.13")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaData/SentinelArrays.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h3vpz7xskbf2a60imdg0irwh9bybkahjpnb6b3wyk0j9a97nqkr"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaData/SentinelArrays.jl")
+ (synopsis "Array types using sentinel values")
+ (description "This package provides @code{SentinelArray{T}} that wraps an
+@code{AbstractArray} of type @code{T}, and accepts a sentinel and value
+argument.")
+ (license license:expat)))
+
(define-public julia-showoff
(package
(name "julia-showoff")