summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-25 02:05:12 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-29 16:47:22 +0200
commit33e5152aeb1ae6d7dc4da792173492e92875a8d7 (patch)
tree005e6870dce6d6190cfbf46a8d4fc74c6b9a2399 /gnu/packages/julia-xyz.scm
parent3d98a16ab4d4f35211d79f25bb46bf74629c1408 (diff)
downloadguix-patches-33e5152aeb1ae6d7dc4da792173492e92875a8d7.tar
guix-patches-33e5152aeb1ae6d7dc4da792173492e92875a8d7.tar.gz
gnu: Add julia-diffrules.
* gnu/packages/julia-xyz.scm (julia-diffrules): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 4bd5a1f9a3..fe1ecf0c9d 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -411,6 +411,31 @@ including, @code{CircularBuffer}, @code{Queue}, @code{Stack},
be passed to in-place differentiation methods instead of an output buffer.")
(license license:expat)))
+(define-public julia-diffrules
+ (package
+ (name "julia-diffrules")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaDiff/DiffRules.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cwjvj4gma7924fm3yas0nf0jlnwwx4v7fi79ii3s290lkdldzfl"))))
+ (propagated-inputs
+ `(("julia-nanmath" ,julia-nanmath)
+ ("julia-specialfunctions" ,julia-specialfunctions)))
+ (build-system julia-build-system)
+ (home-page "https://github.com/JuliaDiff/DiffRules.jl")
+ (synopsis "Primitive differentiation rules")
+ (description "This package provides primitive differentiation rules that
+can be composed via various formulations of the chain rule. Using
+@code{DiffRules}, new differentiation rules can defined, query whether or not
+a given rule exists, and symbolically apply rules to simple Julia expressions.")
+ (license license:expat)))
+
(define-public julia-difftests
(package
(name "julia-difftests")