summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:04:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:57:25 +0300
commit3069985482448d7615d3fe71deab77267f32a6c1 (patch)
treeb19b15884bf8636093b2d0151eac30250eef66a1 /gnu/packages/julia-xyz.scm
parent567fa057d22512f81a465802da4fda1d1b72842e (diff)
downloadguix-patches-3069985482448d7615d3fe71deab77267f32a6c1.tar
guix-patches-3069985482448d7615d3fe71deab77267f32a6c1.tar.gz
gnu: Add julia-blockbandedmatrices.
* gnu/packages/julia-xyz.scm (julia-blockbandedmatrices): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 6896cf2d64..ccaf8f4765 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -223,6 +223,34 @@ extraction and insertion of blocks while @code{PseudoBlockArray} supports fast
access to the full matrix to use in in for example a linear solver.")
(license license:expat)))
+(define-public julia-blockbandedmatrices
+ (package
+ (name "julia-blockbandedmatrices")
+ (version "0.10.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaMatrices/BlockBandedMatrices.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q9ni4pgdkb00jb42fdzlhx745852xx2666vr96k0c4l0cn5mi0y"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-arraylayouts" ,julia-arraylayouts)
+ ("julia-bandedmatrices" ,julia-bandedmatrices)
+ ("julia-blockarrays" ,julia-blockarrays)
+ ("julia-fillarrays" ,julia-fillarrays)
+ ("julia-matrixfactorizations" ,julia-matrixfactorizations)))
+ (home-page "https://github.com/JuliaMatrices/BlockBandedMatrices.jl")
+ (synopsis "Block-banded matrices and banded-block-banded matrices")
+ (description "This package supports representing block-banded and
+banded-block-banded matrices by only storing the entries in the non-zero bands.
+A @code{BlockBandedMatrix} is a subtype of @code{BlockMatrix} of
+@code{BlockArrays.jl} whose layout of non-zero blocks is banded.")
+ (license license:expat)))
+
(define-public julia-bufferedstreams
(package
(name "julia-bufferedstreams")