summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-31 11:25:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:54:47 +0300
commit2615a8bad5171d5802067ee98b00472f6a71c57a (patch)
tree5a3aecbd0e950f0a3996bd7bbeec516af472da5c /gnu/packages/julia-xyz.scm
parentfa945a540cb2a36a63d50b349a9ea697bf4b8340 (diff)
downloadguix-patches-2615a8bad5171d5802067ee98b00472f6a71c57a.tar
guix-patches-2615a8bad5171d5802067ee98b00472f6a71c57a.tar.gz
gnu: Add julia-optimtestproblems.
* gnu/packages/julia-xyz.scm (julia-optimtestproblems): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 8fe4f8bac1..9676466527 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1285,6 +1285,28 @@ Julia, with type-driven, overloadable packing/unpacking functionality.")
@code{NaN} instead of throwing a @code{DomainError}.")
(license license:expat)))
+(define-public julia-optimtestproblems
+ (package
+ (name "julia-optimtestproblems")
+ (version "2.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaNLSolvers/OptimTestProblems.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10h47x5ws42pkqjccimaz0yxfvz41w0yazq6inamfk4lg5g2g3d9"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:julia-package-name "OptimTestProblems"))
+ (home-page "https://github.com/JuliaNLSolvers/OptimTestProblems.jl")
+ (synopsis "Collection of optimization test problems")
+ (description "The purpose of this package is to provide test problems for
+JuliaNLSolvers packages.")
+ (license license:expat)))
+
(define-public julia-orderedcollections
(package
(name "julia-orderedcollections")