summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-04 15:33:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-12 08:32:47 +0300
commit0d8886679726561e3ecc1c9db1263976107b8bc2 (patch)
tree6239300074041390456b09fc8f43b31a8ca1cd9f /gnu/packages/julia-xyz.scm
parentb224cf8a0d8aab8d3269626a3adb55efe8b19174 (diff)
downloadguix-patches-0d8886679726561e3ecc1c9db1263976107b8bc2.tar
guix-patches-0d8886679726561e3ecc1c9db1263976107b8bc2.tar.gz
gnu: Add julia-latexstrings.
* gnu/packages/julia-xyz.scm (julia-latexstrings): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 9acef0742b..3876b409e9 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2407,6 +2407,28 @@ and printing JSON documents.")
focus on speed and slick struct mapping.")
(license license:expat)))
+(define-public julia-latexstrings
+ (package
+ (name "julia-latexstrings")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stevengj/LaTeXStrings.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "117z27krcf8fydgp6mb0pgn75r4gng9qs7v90qb4bqzsry3faadp"))))
+ (build-system julia-build-system)
+ (native-inputs
+ `(("julia-documenter" ,julia-documenter)))
+ (home-page "https://github.com/stevengj/LaTeXStrings.jl")
+ (synopsis "Input and display of LaTeX equation strings")
+ (description "This is a small package to make it easier to type LaTeX
+equations in string literals in the Julia language.")
+ (license license:expat)))
+
(define-public julia-lazyarrays
(package
(name "julia-lazyarrays")