summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 11:20:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:51 +0300
commit0c1b3444e1924c0998820f83ed6f4bea23eb36c7 (patch)
treebab1539070ba715a54a3b8556ee3148f7ad982c3 /gnu/packages/julia-xyz.scm
parent94963f09bf5a67e88e89cc682c31af7116827776 (diff)
downloadguix-patches-0c1b3444e1924c0998820f83ed6f4bea23eb36c7.tar
guix-patches-0c1b3444e1924c0998820f83ed6f4bea23eb36c7.tar.gz
gnu: Add julia-ffmpeg.
* gnu/packages/julia-xyz.scm (julia-ffmpeg): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index ff207456c3..60e518e251 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -596,6 +596,30 @@ stressing the robustness of differentiation tools.")
(description "This package provides various examples.")
(license license:expat))))
+(define-public julia-ffmpeg
+ (package
+ (name "julia-ffmpeg")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaIO/FFMPEG.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kwqixwhnnxs59xsw2k44xxnkx5fn4y49g58l5snfbszycxq7lls"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-ffmpeg-jll" ,julia-ffmpeg-jll)
+ ("julia-x264-jll" ,julia-x264-jll)))
+ (home-page "https://github.com/JuliaIO/FFMPEG.jl")
+ (synopsis "Julia Package for ffmpeg")
+ (description "This package is made to be included into packages that just
+need the ffmpeg binaries + executables, and don't want the overhead of
+@code{VideoIO.jl}.")
+ (license license:expat)))
+
(define-public julia-fillarrays
(package
(name "julia-fillarrays")