summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-14 10:39:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-14 14:45:20 +0300
commit08ad8d69ed47aa4bb81764f8b4ba89f8e7eea9e0 (patch)
treee6cacc2c36221914466864485f688d6ac53fcd65 /gnu/packages/julia-xyz.scm
parenta5daa8c0ab400bffc53f245069a62c9503addf63 (diff)
downloadguix-patches-08ad8d69ed47aa4bb81764f8b4ba89f8e7eea9e0.tar
guix-patches-08ad8d69ed47aa4bb81764f8b4ba89f8e7eea9e0.tar.gz
gnu: Add julia-filepathsbase.
* gnu/packages/julia-xyz.scm (julia-filepathsbase): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index bd24f814a5..44b9533575 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -974,6 +974,28 @@ need the ffmpeg binaries + executables, and don't want the overhead of
@code{VideoIO.jl}.")
(license license:expat)))
+(define-public julia-filepathsbase
+ (package
+ (name "julia-filepathsbase")
+ (version "0.9.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rofinn/FilePathsBase.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "136wm4ik6isrdanmpi4gdr1qw0qhr15i925qzjxbawk5hnyzwng9"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:tests? #f)) ; Cycle with JLSO.jl
+ (home-page "https://github.com/rofinn/FilePathsBase.jl")
+ (synopsis "Filesystem path types in Julia")
+ (description "@code{FilePathsBase.jl} provides a type based approach to
+working with filesystem paths in Julia.")
+ (license license:expat)))
+
(define-public julia-fillarrays
(package
(name "julia-fillarrays")