summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2021-01-30 15:47:29 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-20 22:29:14 +0100
commit03010d5d3efd4ac19c4bddea67cbfe09c129db8d (patch)
tree8f97e99ef9c197f481ba3a69f49df77937e7c13a /gnu/packages/julia-xyz.scm
parent81d45a66d57158ec1d07723d99eb0b9e789b8ec2 (diff)
downloadguix-patches-03010d5d3efd4ac19c4bddea67cbfe09c129db8d.tar
guix-patches-03010d5d3efd4ac19c4bddea67cbfe09c129db8d.tar.gz
gnu: Add julia-benchmarktools.
* gnu/packages/julia-xyz.scm (julia-benchmarktools): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index c9e1d0df8c..09043c593b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -44,6 +44,28 @@ acts like @code{convert(T, x)}, but without the restriction of returning a
be GPU compatible without throwing away the wrapper.")
(license license:expat)))
+(define-public julia-benchmarktools
+ (package
+ (name "julia-benchmarktools")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaCI/BenchmarkTools.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nsx21m3i5h22lkgyrmfj6r085va6ag40khwssqs8y7l0wz98lvp"))))
+ (build-system julia-build-system)
+ (propagated-inputs `(("julia-json" ,julia-json)))
+ (home-page "https://github.com/JuliaCI/BenchmarkTools.jl")
+ (synopsis "Benchmarking framework for the Julia language")
+ (description "@code{BenchmarkTools.jl} makes performance tracking of Julia
+code easy by supplying a framework for writing and running groups of
+benchmarks as well as comparing benchmark results.")
+ (license license:expat)))
+
(define-public julia-compat
(package
(name "julia-compat")