summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:08:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:52 +0300
commite2ee6686efe11a439bb5c09a5d3543e78f4579f1 (patch)
tree03da2e90ac04ead507c78fe18b785f4f99608144 /gnu/packages/julia-jll.scm
parenta4dbdbaccfd5eda4ef0992b5f8ed4cae8f575cef (diff)
downloadguix-patches-e2ee6686efe11a439bb5c09a5d3543e78f4579f1.tar
guix-patches-e2ee6686efe11a439bb5c09a5d3543e78f4579f1.tar.gz
gnu: Add julia-libuuid-jll.
* gnu/packages/julia-jll.scm (julia-libuuid-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 2210778065..651d15599b 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -809,6 +809,44 @@ from util-linux.")
(description "This package provides a wrapper for libtiff")
(license license:expat)))
+(define-public julia-libuuid-jll
+ (package
+ (name "julia-libuuid-jll")
+ (version "2.36.0+0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Libuuid_jll.jl")
+ (commit (string-append "Libuuid-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0iz1qrrpl8sp336m1f884sdgwbdlkp9sm371cwcfq4iriaihbmbs"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"Libuuid\", \""
+ (assoc-ref inputs "util-linux") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("util-linux" ,util-linux "lib")))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Libmount_jll.jl")
+ (synopsis "Libuuid library wrappers")
+ (description "This package provides a wrapper for the libuuid library from util-linux.")
+ (license license:expat)))
+
(define-public julia-libvorbis-jll
(package
(name "julia-libvorbis-jll")