summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:26:49 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:54 +0300
commitd604f4fc5359cc887870c975bc8dcb8301b0e9b4 (patch)
tree686e64328e3828fd1a6bc8be59dd7aa03c430cbb /gnu/packages/julia-jll.scm
parent7cb9173879aa814fd89e21d98035081f9f86e05b (diff)
downloadguix-patches-d604f4fc5359cc887870c975bc8dcb8301b0e9b4.tar
guix-patches-d604f4fc5359cc887870c975bc8dcb8301b0e9b4.tar.gz
gnu: Add julia-fontconfig-jll.
* gnu/packages/julia-jll.scm (julia-fontconfig-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 7cf8899c94..80b6b4c5c3 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -222,6 +222,49 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for ffmpeg.")
(license license:expat)))
+(define-public julia-fontconfig-jll
+ (package
+ (name "julia-fontconfig-jll")
+ (version "2.13.93+0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Fontconfig_jll.jl")
+ (commit (string-append "Fontconfig-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1p6mfci77bp31w3xzlwhjccln40g6g2rdpfp38v5xf8sz2aybpw2"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"Fontconfig\", \""
+ (assoc-ref inputs "fontconfig") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("fontconfig" ,fontconfig)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-bzip2-jll" ,julia-bzip2-jll)
+ ("julia-expat-jll" ,julia-expat-jll)
+ ("julia-freetype2-jll" ,julia-freetype2-jll)
+ ("julia-libuuid-jll" ,julia-libuuid-jll)
+ ("julia-zlib-jll" ,julia-zlib-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Fontconfig_jll.jl")
+ (synopsis "Fontconfig library wrappers")
+ (description "This package provides a wrapper for the fontconfig library.")
+ (license license:expat)))
+
(define-public julia-freetype2-jll
(package
(name "julia-freetype2-jll")