summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 11:29:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:52 +0300
commitceb7936ff524565db5f307e3ed725e07d718a77c (patch)
treefca40965e0d9adae4295857b4cadcf02705335dc /gnu/packages/julia-jll.scm
parent7180dcdfb1c31b9cff8932995902b17e3c62bce9 (diff)
downloadguix-patches-ceb7936ff524565db5f307e3ed725e07d718a77c.tar
guix-patches-ceb7936ff524565db5f307e3ed725e07d718a77c.tar.gz
gnu: Add julia-gettext-jll.
* gnu/packages/julia-jll.scm (julia-gettext-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 96f9b1b84a..658acc4563 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -31,6 +31,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages julia)
@@ -255,6 +256,47 @@ rendering library.")
(description "This package provides a wrapper for the fribidi library.")
(license license:expat)))
+(define-public julia-gettext-jll
+ (package
+ (name "julia-gettext-jll")
+ (version "0.21.0+0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Gettext_jll.jl")
+ (commit (string-append "Gettext-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ghwkwv970q6j9ggkl0zlyrflhx8rd39y5i2zkc6p26084kyrxmf"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"Gettext\", \""
+ (assoc-ref inputs "gettext") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("gettext" ,gettext-minimal)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-compilersupportlibraries-jll" ,julia-compilersupportlibraries-jll)
+ ("julia-libiconv-jll" ,julia-libiconv-jll)
+ ("julia-xml2-jll" ,julia-xml2-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Gettext_jll.jl")
+ (synopsis "Gettext library wrappers")
+ (description "This package provides a wrapper for the gettext library.")
+ (license license:expat)))
+
(define-public julia-gumbo-jll
(package
(name "julia-gumbo-jll")