summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-28 15:31:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-28 16:05:33 +0300
commitcbee53439127c6fab752e023c6b52c186b03117c (patch)
tree2122a4186e5d0c3eb330c44e479f78245b8876fd /gnu/packages/julia-jll.scm
parentf7eaa69dc2effb75ff17a2f91d6a31f3b335ee1c (diff)
downloadguix-patches-cbee53439127c6fab752e023c6b52c186b03117c.tar
guix-patches-cbee53439127c6fab752e023c6b52c186b03117c.tar.gz
gnu: julia-jllwrappers: Add julia-preferences.
* gnu/packages/julia-jll.scm (julia-jllwrappers)[propagated-inputs]: Add julia-preferences.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 508d42aa95..d18971ad48 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -40,6 +40,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages julia)
+ #:use-module (gnu packages julia-xyz)
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
#:use-module (gnu packages maths)
@@ -639,6 +640,8 @@ rendering library.")
(("return joinpath.*") "return $override\n"))
#t)))))
(build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-preferences" ,julia-preferences)))
(home-page "https://github.com/JuliaPackaging/JLLWrappers.jl")
(synopsis "Julia macros used by JLL packages")
(description "This package contains Julia macros that enable JLL packages