summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-14 15:43:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-09-30 14:20:15 +0300
commitac1166fbdb993c29dd87f210f7933e3e54c02124 (patch)
treeb99686021f4d3712e60955c746db888e24b4871b /gnu/packages/julia-jll.scm
parent60d3484f7c4a1c5a459d5e98bf44390a6bbc36ab (diff)
downloadguix-patches-ac1166fbdb993c29dd87f210f7933e3e54c02124.tar
guix-patches-ac1166fbdb993c29dd87f210f7933e3e54c02124.tar.gz
gnu: Add julia-libsass-jll.
* gnu/packages/julia-jll.scm (julia-libsass-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index d18971ad48..d3677d0a33 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1064,6 +1064,49 @@ from util-linux.")
(description "This package provides a wrapper for the libpng library.")
(license license:expat)))
+(define-public julia-libsass-jll
+ (let ((commit "69bf10603aad0ebf1f6df088c5fd7c4a5d1eb0ca"))
+ (package
+ (name "julia-libsass-jll")
+ (version "3.5.5+0") ;tag not created upstream
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/libsass_jll.jl")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fb6rf422533bsmfslvc20ag1hr50bf9xaj32rvh7nv593sbiygn"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:tests? #f ; no runtests.jl
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"libsass\", \""
+ (assoc-ref inputs "libsass") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$"))
+ #t)))))
+ (inputs
+ `(("libsass" ,libsass)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/libsass_jll.jl")
+ (synopsis "Julia wrapper for libsass")
+ (description "This package provides a wrapper for libsass. It is an
+autogenerated source package constructed using @code{BinaryBuilder.jl}. The
+originating @code{build_tarballs.jl} script can be found on the community
+build tree Yggdrasil.")
+ (license license:expat))))
+
(define-public julia-libtiff-jll
(package
(name "julia-libtiff-jll")