summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:32:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:55 +0300
commit92873d3bfe2fd2016892801b10040d5b6f17e514 (patch)
treea04dbbc3bd1a81f1e84aab80cc49939b3a69c2b1 /gnu/packages/julia-jll.scm
parent98cfe462c290219582de87eddeabc5671842891e (diff)
downloadguix-patches-92873d3bfe2fd2016892801b10040d5b6f17e514.tar
guix-patches-92873d3bfe2fd2016892801b10040d5b6f17e514.tar.gz
gnu: Add julia-xorg-libxcursor-jll.
* gnu/packages/julia-jll.scm (julia-xorg-libxcursor-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index ac16c52693..32602f3f1b 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1666,6 +1666,44 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the libxcb library.")
(license license:expat)))
+(define-public julia-xorg-libxcursor-jll
+ (package
+ (name "julia-xorg-libxcursor-jll")
+ (version "1.2.0+3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Xorg_libXcursor_jll.jl")
+ (commit (string-append "Xorg_libXcursor-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hxhpsjw1zk30qphrp90g1wvqfs1hr47qifn1gqgx73ci5nmq0y7"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Xorg_libXcursor\"")
+ (string-append "\"" (assoc-ref inputs "libxcursor") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libxcursor" ,libxcursor)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-xorg-libxfixes-jll" ,julia-xorg-libxfixes-jll)
+ ("julia-xorg-libxrender-jll" ,julia-xorg-libxrender-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Xorg_libXcursor_jll.jl")
+ (synopsis "Libxcursor library wrappers")
+ (description "This package provides a wrapper for the libxcursor library.")
+ (license license:expat)))
+
(define-public julia-xorg-libxdmcp-jll
(package
(name "julia-xorg-libxdmcp-jll")