summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:53:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:50 +0300
commit741aab4c424732d2c052d873a660f94c676e9f92 (patch)
tree43fb960a97130d988e8e9c11659191a7ee6e6c2a /gnu/packages/julia-jll.scm
parenta1b7d59ca61f687804bc5958e1fa08fda27d43c5 (diff)
downloadguix-patches-741aab4c424732d2c052d873a660f94c676e9f92.tar
guix-patches-741aab4c424732d2c052d873a660f94c676e9f92.tar.gz
gnu: Add julia-freetype2-jll.
* gnu/packages/julia-jll.scm (julia-freetype2-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index fc3e5ab723..26df3eec79 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -26,6 +26,7 @@
#:use-module (guix build-system julia)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages fontutils)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gcc)
#:use-module (gnu packages image)
@@ -121,6 +122,48 @@ originating @code{build_tarballs.jl} script can be found on the community
build tree Yggdrasil.")
(license license:expat)))
+(define-public julia-freetype2-jll
+ (package
+ (name "julia-freetype2-jll")
+ (version "2.10.4+0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/FreeType2_jll.jl")
+ (commit (string-append "FreeType2-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03lgmb59lipc3bi7z22j4a53bbjmcwkf0xzpwan889p1ix3ry1lr"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; No runtests.jl
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"FreeType2\", \""
+ (assoc-ref inputs "freetype") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$"))
+ #t)))))
+ (inputs
+ `(("freetype" ,freetype)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-bzip2-jll" ,julia-bzip2-jll)
+ ("julia-zlib-jll" ,julia-zlib-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/FreeType2_jll.jl")
+ (synopsis "Freetype2 binary wrappers")
+ (description "This Julia module provides a wrapper for the freetype font
+rendering library.")
+ (license license:expat)))
+
(define-public julia-fribidi-jll
(package
(name "julia-fribidi-jll")