summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-20 14:51:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-24 11:41:20 +0300
commit6f3a9d4c9b3cb67ba4a7b9cb2eb00394a06ad36c (patch)
tree64122e5ec13e818d6cf376efcc20816351a77559 /gnu/packages/julia-jll.scm
parentb111497f813bb69a273ce47519f0ef0059dfa56e (diff)
downloadguix-patches-6f3a9d4c9b3cb67ba4a7b9cb2eb00394a06ad36c.tar
guix-patches-6f3a9d4c9b3cb67ba4a7b9cb2eb00394a06ad36c.tar.gz
gnu: Add julia-gr-jll.
* gnu/packages/julia-jll.scm (julia-gr-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index d3677d0a33..51643819ae 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages graphics)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
@@ -522,6 +523,55 @@ rendering library.")
(description "This package provides a wrapper for the glib library.")
(license license:expat)))
+(define-public julia-gr-jll
+ (package
+ (name "julia-gr-jll")
+ (version "0.58.1+0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/GR_jll.jl")
+ (commit (string-append "GR-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16m22n0wh86v3lh0im2pc9bg381djbmqji5hjx42j6aaz634gqiq"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"GR\", \""
+ (assoc-ref inputs "gr-framework") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("gr-framework" ,gr-framework)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-bzip2-jll" ,julia-bzip2-jll)
+ ("julia-cairo-jll" ,julia-cairo-jll)
+ ("julia-ffmpeg-jll" ,julia-ffmpeg-jll)
+ ("julia-fontconfig-jll" ,julia-fontconfig-jll)
+ ("julia-glfw-jll" ,julia-glfw-jll)
+ ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
+ ("julia-libpng-jll" ,julia-libpng-jll)
+ ("julia-libtiff-jll" ,julia-libtiff-jll)
+ ("julia-pixman-jll" ,julia-pixman-jll)
+ ("julia-qt5base-jll" ,julia-qt5base-jll)
+ ("julia-zlib-jll" ,julia-zlib-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/GR_jll.jl")
+ (synopsis "GR framework library wrappers")
+ (description "This package provides a wrapper for the GR framework.")
+ (license license:expat)))
+
(define-public julia-gumbo-jll
(package
(name "julia-gumbo-jll")