summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:35:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:55 +0300
commit2cc2507d0e1d1bc30d4ad755dd1e73e21e8bcd1f (patch)
tree6102f9a500c1627d6a238e9b99b8cb077ead6865 /gnu/packages/julia-jll.scm
parent7946cd309bee1322986523290d30b40189be085b (diff)
downloadguix-patches-2cc2507d0e1d1bc30d4ad755dd1e73e21e8bcd1f.tar
guix-patches-2cc2507d0e1d1bc30d4ad755dd1e73e21e8bcd1f.tar.gz
gnu: Add julia-xorg-libxi-jll.
* gnu/packages/julia-jll.scm (julia-xorg-libxi-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 4cfe09d031..e6202dd4a6 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1853,6 +1853,44 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the libxfixes library.")
(license license:expat)))
+(define-public julia-xorg-libxi-jll
+ (package
+ (name "julia-xorg-libxi-jll")
+ (version "1.7.10+3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Xorg_libXi_jll.jl")
+ (commit (string-append "Xorg_libXi-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jhrng5sf44880x3pnw1gpb88z21c7nznfyzhs4a5z910ndrynd7"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Xorg_libXi\"")
+ (string-append "\"" (assoc-ref inputs "libxi") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libxi" ,libxi)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-xorg-libxext-jll" ,julia-xorg-libxext-jll)
+ ("julia-xorg-libxfixes-jll" ,julia-xorg-libxfixes-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Xorg_libXi_jll.jl")
+ (synopsis "Libxi library wrappers")
+ (description "This package provides a wrapper for the libxi library.")
+ (license license:expat)))
+
(define-public julia-xorg-libxrender-jll
(package
(name "julia-xorg-libxrender-jll")