summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:25:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:54 +0300
commit2b93e8cd66bf4f1e296528e62e866468a941f8ad (patch)
tree0828bba749b2a0f5c3cb1d33d5ab00fde2d1442d /gnu/packages/julia-jll.scm
parent6b10ebc98a086dcab861950411627929342d696e (diff)
downloadguix-patches-2b93e8cd66bf4f1e296528e62e866468a941f8ad.tar
guix-patches-2b93e8cd66bf4f1e296528e62e866468a941f8ad.tar.gz
gnu: Add julia-xorg-libx11-jll.
* gnu/packages/julia-jll.scm (julia-xorg-libx11-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 933867a447..33e7740298 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1462,6 +1462,44 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the libpthread-stubs library.")
(license license:expat)))
+(define-public julia-xorg-libx11-jll
+ (package
+ (name "julia-xorg-libx11-jll")
+ (version "1.6.9+2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Xorg_libX11_jll.jl")
+ (commit (string-append "Xorg_libX11-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fw2dmmw04jmyss43g66q80w3j7wshmxgjccir1hh4c5d8x2zs39"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Xorg_libX11\"")
+ (string-append "\"" (assoc-ref inputs "libx11") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libx11" ,libx11)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-xorg-libxcb-jll" ,julia-xorg-libxcb-jll)
+ ("julia-xorg-xtrans-jll" ,julia-xorg-xtrans-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Xorg_libX11_jll.jl")
+ (synopsis "LibX11 library wrappers")
+ (description "This package provides a wrapper for the libx11 library.")
+ (license license:expat)))
+
(define-public julia-xorg-libxau-jll
(package
(name "julia-xorg-libxau-jll")