summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:47:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:57 +0300
commit24ad2dc77c6a7748a3b0a0c428d26db848d7b0d9 (patch)
tree13472d6d5fead65534058ac2222b077c5a079cf3 /gnu/packages/julia-jll.scm
parent13b118108d011362b8f0ba1957326b2c5eedd422 (diff)
downloadguix-patches-24ad2dc77c6a7748a3b0a0c428d26db848d7b0d9.tar
guix-patches-24ad2dc77c6a7748a3b0a0c428d26db848d7b0d9.tar.gz
gnu: Add julia-xorg-xcb-util-keysyms-jll.
* gnu/packages/julia-jll.scm (julia-xorg-xcb-util-keysyms-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index f05ff7e75c..336de41aa5 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -2274,6 +2274,43 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the xcb-util-image library.")
(license license:expat)))
+(define-public julia-xorg-xcb-util-keysyms-jll
+ (package
+ (name "julia-xorg-xcb-util-keysyms-jll")
+ (version "0.4.0+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Xorg_xcb_util_keysyms_jll.jl")
+ (commit (string-append "Xorg_xcb_util_keysyms-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03i3fw9p16rpjnki80w4rhmaiqvjlfsr94bf9yizndqsw1lcq42l"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Xorg_xcb_util_keysyms\"")
+ (string-append "\"" (assoc-ref inputs "xcb-util-keysyms") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("xcb-util-keysyms" ,xcb-util-keysyms)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-xorg-xcb-util-jll" ,julia-xorg-xcb-util-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Xorg_xcb_util_keysyms_jll.jl")
+ (synopsis "Xcb-util-keysyms library wrappers")
+ (description "This package provides a wrapper for the xcb-util-keysyms library.")
+ (license license:expat)))
+
(define-public julia-xorg-xcb-util-wm-jll
(package
(name "julia-xorg-xcb-util-wm-jll")