summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:42:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:49 +0300
commit191c345d3ea78beae0b4a2ad4e26cd2f51222cb4 (patch)
treec93ebaac487e906d97caf19c501c32f08e6df8fb /gnu/packages/julia-jll.scm
parentda12e8f7c79aa3821678721c168965325bd83c5b (diff)
downloadguix-patches-191c345d3ea78beae0b4a2ad4e26cd2f51222cb4.tar
guix-patches-191c345d3ea78beae0b4a2ad4e26cd2f51222cb4.tar.gz
gnu: julia-imagemagick-jll: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-imagemagick-jll): Move to ... * gnu/packages/julia-jll.scm: ... here.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index e8d382afea..7fcc11957a 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -28,6 +28,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
#:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages julia)
#:use-module (gnu packages maths)
#:use-module (gnu packages tls)
@@ -117,6 +118,49 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for Gumbo HTML parsing library.")
(license license:expat)))
+(define-public julia-imagemagick-jll
+ (package
+ (name "julia-imagemagick-jll")
+ (version "6.9.10-12+3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/ImageMagick_jll.jl")
+ (commit (string-append "ImageMagick-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1a0vnnjl52yqi7jgpr0dmx5ah5nlpylv5hc8aw2l89b9f36ff8jg"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ ;; Make sure we match the current library.
+ (("libMagickWand-6.Q16.so.6") "libMagickWand-6.Q16.so.7")
+ (("artifact\"ImageMagick\"")
+ (string-append "\"" (assoc-ref inputs "imagemagick") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
+ ("julia-libpng-jll" ,julia-libpng-jll)
+ ("julia-libtiff-jll" ,julia-libtiff-jll)
+ ("julia-zlib-jll" ,julia-zlib-jll)))
+ (inputs
+ `(("imagemagick" ,imagemagick)))
+ (home-page "https://github.com/JuliaBinaryWrappers/ImageMagick_jll.jl")
+ (synopsis "Imagemagick library wrappers")
+ (description "This package provides a wrapper for Imagemagick.")
+ (license license:expat)))
+
(define-public julia-jllwrappers
(package
(name "julia-jllwrappers")