summaryrefslogtreecommitdiff
path: root/gnu/packages/jrnl.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-06-30 11:26:08 -0500
committerEric Bavier <bavier@member.fsf.org>2014-06-30 11:26:42 -0500
commitcafc3f5ad76b534662ced753f7f2f07841da6bf4 (patch)
tree9aaf05f696fa25d14f3d680e75ac52028e91a680 /gnu/packages/jrnl.scm
parent71639e1f17212e6f3f63a8a9b6f84ee2a4d2018e (diff)
downloadguix-patches-cafc3f5ad76b534662ced753f7f2f07841da6bf4.tar
guix-patches-cafc3f5ad76b534662ced753f7f2f07841da6bf4.tar.gz
gnu: Add jrnl, python-pycrypto, python-keyring, python-parsedatetime, and python-tzlocal.
* gnu/packages/jrnl.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it. * gnu/packages/python.scm (python-pycrypto, python-keyring, python-dateutil-2, python-parsedatetime, python-tzlocal): New variables.
Diffstat (limited to 'gnu/packages/jrnl.scm')
-rw-r--r--gnu/packages/jrnl.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/jrnl.scm b/gnu/packages/jrnl.scm
new file mode 100644
index 0000000000..bdd4471c41
--- /dev/null
+++ b/gnu/packages/jrnl.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Eric Bavier <address@hidden>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages jrnl)
+ #:use-module (guix packages)
+ #:use-module (guix licenses)
+ #:use-module (guix download)
+ #:use-module (guix build-system python)
+ #:use-module (gnu packages python))
+
+(define-public jrnl
+ (package
+ (name "jrnl")
+ (version "1.8.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/maebert/jrnl/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "019ky09sj5i7frmca0imv4jm46mn3f4lzah2wmiwxh22cisj7ksn"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("behave" ,behave)))
+ (inputs
+ `(("python" ,python)
+ ("python-keyring" ,python-keyring)
+ ("python-pycrypto" ,python-pycrypto)
+ ("python-pytz" ,python-pytz)
+ ("python-tzlocal" ,python-tzlocal)
+ ("python-six" ,python-six)
+ ("python-dateutil" , python-dateutil-2)
+ ("python-parsedatetime" ,python-parsedatetime)))
+ (home-page "http://maebert.github.io/jrnl/")
+ (synopsis "Personal journal application")
+ (description
+ "Jrnl is a command line journal application that stores your journal in a
+plain text file. Optionally, your journal can be encrypted using 256-bit AES
+encryption.")
+ (license x11)))