summaryrefslogtreecommitdiff
path: root/gnu/packages/jemalloc.scm
diff options
context:
space:
mode:
authorNikolai Merinov <nikolai.merinov@member.fsf.org>2017-12-11 02:14:01 +0500
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-11 00:05:30 +0100
commitd53fb678a72a83401f0495b458bd0dcc6428d364 (patch)
tree14a70e75e570841ddd42e26e91e86c9e62f72445 /gnu/packages/jemalloc.scm
parent3b80b81358b3861ca3794105c8eb4395df97846b (diff)
downloadguix-patches-d53fb678a72a83401f0495b458bd0dcc6428d364.tar
guix-patches-d53fb678a72a83401f0495b458bd0dcc6428d364.tar.gz
gnu: rust: Update rust to 1.22.1 and cargo to 1.23.0.
* gnu/packages/rust.scm (%rust-bootstrap-binaries-version): Update version. (%rust-bootstrap-binaries): Use x86_64 rust bootstrap package for x86_64 build. (%cargo-reference-project-file): Use specific file as "project" file when patching rust vendored sources. (%cargo-reference-hash): sha256 sum for %cargo-reference-project-file. (rustc-bootstrap): Use bootstrap package with host architecture. (cargo-bootstrap): Use bootstrap package with host architecture. (rustc): Add new test dependency, fix build issues, use "./x.py" script for build instead of "./configure". (cargo): Update dependencies, patch shebangs for vendored sources * gnu/packages/jemalloc.scm: Add jemalloc-4.5.0 release. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/jemalloc.scm')
-rw-r--r--gnu/packages/jemalloc.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/jemalloc.scm b/gnu/packages/jemalloc.scm
index a3bd2c93a4..5e3e32df84 100644
--- a/gnu/packages/jemalloc.scm
+++ b/gnu/packages/jemalloc.scm
@@ -23,6 +23,7 @@
#:use-module ((guix licenses) #:select (bsd-2))
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module (gnu packages perl)
#:use-module (guix build-system gnu))
@@ -62,3 +63,17 @@
"This library providing a malloc(3) implementation that emphasizes
fragmentation avoidance and scalable concurrency support.")
(license bsd-2)))
+
+(define-public jemalloc-4.5.0
+ (package
+ (inherit jemalloc)
+ (version "4.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/jemalloc/jemalloc/releases/download/"
+ version "/jemalloc-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "10373xhpc10pgmai9fkc1z0rs029qlcb3c0qfnvkbwdlcibdh2cl"))))
+ (inputs '())))