summaryrefslogtreecommitdiff
path: root/gnu/packages/jemalloc.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-16 16:46:03 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-18 21:52:14 +0800
commit82d8729b24bc4dfec638373dd561ced40f4933d9 (patch)
tree888a3589f36764066acd52ffb1be2e4c340a4b79 /gnu/packages/jemalloc.scm
parent40f6f76ed1eb29673f1da5eb9f976c566104abe6 (diff)
downloadguix-patches-82d8729b24bc4dfec638373dd561ced40f4933d9.tar
guix-patches-82d8729b24bc4dfec638373dd561ced40f4933d9.tar.gz
gnu: Add jemalloc.
* gnu/packages/jemalloc.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/jemalloc.scm')
-rw-r--r--gnu/packages/jemalloc.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/jemalloc.scm b/gnu/packages/jemalloc.scm
new file mode 100644
index 0000000000..8a25cb08b8
--- /dev/null
+++ b/gnu/packages/jemalloc.scm
@@ -0,0 +1,43 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages jemalloc)
+ #:use-module ((guix licenses) #:select (bsd-2))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public jemalloc
+ (package
+ (name "jemalloc")
+ (version "3.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.canonware.com/download/jemalloc/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1zl4vxxjvhg72bdl53sl0idz9wp18c6yzjdmqcnwm09wvmcj2v71"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.canonware.com/jemalloc/")
+ (synopsis "General-purpose scalable concurrent malloc implementation")
+ (description
+ "This library providing a malloc(3) implementation that emphasizes
+fragmentation avoidance and scalable concurrency support.")
+ (license bsd-2)))