summaryrefslogtreecommitdiff
path: root/gnu/packages/jemalloc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-01 16:11:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-01 16:13:53 +0300
commit0fdf2cdef0c0ab8a43a539e2917d82c8ee4c4e73 (patch)
tree3445f87104dde202f0407a845f27b102d91d347a /gnu/packages/jemalloc.scm
parent9ba35475ede5eb61bfeead096bc6b73f123ac891 (diff)
downloadguix-patches-0fdf2cdef0c0ab8a43a539e2917d82c8ee4c4e73.tar
guix-patches-0fdf2cdef0c0ab8a43a539e2917d82c8ee4c4e73.tar.gz
gnu: jemalloc: Fix building on powerpc-linux.
* gnu/packages/jemalloc.scm (jemalloc)[arguments]: Change configure-flags so they are configurable per-architecture.
Diffstat (limited to 'gnu/packages/jemalloc.scm')
-rw-r--r--gnu/packages/jemalloc.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/jemalloc.scm b/gnu/packages/jemalloc.scm
index 906330a4b6..96713dbe52 100644
--- a/gnu/packages/jemalloc.scm
+++ b/gnu/packages/jemalloc.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
-;;; Copyright © 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
@@ -21,6 +21,7 @@
(define-module (gnu packages jemalloc)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
+ #:use-module (ice-9 match)
#:use-module ((guix licenses) #:select (bsd-2))
#:use-module (guix packages)
#:use-module (guix download)
@@ -52,12 +53,14 @@
(substitute* "Makefile.in"
(("\\$\\(srcroot\\)test/unit/pages.c \\\\") "\\"))
#t)))
- ,@(if (any (cute string-prefix? <> (or (%current-target-system)
- (%current-system)))
- '("x86_64" "i686"))
- ;; Transparent huge pages are only enabled by default on Intel processors
- '()
- '(#:configure-flags (list "--disable-thp")))))
+ #:configure-flags
+ '(,@(match (%current-system)
+ ((or "i686-linux" "x86_64-linux")
+ '())
+ ("powerpc-linux"
+ (list "--disable-thp" "CPPFLAGS=-maltivec"))
+ (_
+ (list "--disable-thp"))))))
(inputs `(("perl" ,perl)))
;; Install the scripts to a separate output to avoid referencing Perl and
;; Bash in the default output, saving ~75 MiB on the closure.