summaryrefslogtreecommitdiff
path: root/gnu/packages/javascript.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-28 22:04:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-30 04:42:54 +0200
commit9986316618c471a9a100d1b317a342aee8d5e6df (patch)
treed6d0faa63eb3da5c7b03d54269e68b91a0617d4b /gnu/packages/javascript.scm
parentbfb994d8be24d27378d77d0d280cf01b44eaa344 (diff)
downloadguix-patches-9986316618c471a9a100d1b317a342aee8d5e6df.tar
guix-patches-9986316618c471a9a100d1b317a342aee8d5e6df.tar.gz
gnu: mujs: Update to 1.0.4.
* gnu/packages/javascript.scm (mujs): Update to 1.0.4.
Diffstat (limited to 'gnu/packages/javascript.scm')
-rw-r--r--gnu/packages/javascript.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index 3a9e88ad08..75517caf6b 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
@@ -26,6 +26,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages lisp)
+ #:use-module (gnu packages readline)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -412,7 +413,7 @@ external server.")
(define-public mujs
(package
(name "mujs")
- (version "1.0.3")
+ (version "1.0.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -421,14 +422,16 @@ external server.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "15ml3rzjl44lqdb1yxipdh8bhh0rvk2g6w6sjv667q8xywijwqv8"))))
+ "1ly0yybs66nk63517kg4dmdc7dbikhqqqf2r2kvccgzzvv6k0vs8"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (delete 'configure)) ; no configure
+ (delete 'configure)) ; no configure
#:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out"))
(string-append "CC=gcc"))
- #:tests? #f)) ; no tests
+ #:tests? #f)) ; no tests
+ (inputs
+ `(("readline" ,readline)))
(home-page "https://artifex.com/mujs/")
(synopsis "JavaScript interpreter written in C")
(description "MuJS is a lightweight Javascript interpreter designed for