summaryrefslogtreecommitdiff
path: root/gnu/packages/javascript.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-17 01:00:50 -0400
committerMark H Weaver <mhw@netris.org>2018-05-17 01:00:50 -0400
commit539bf8f2c071b53834829259bb3fabf0390c5dc6 (patch)
tree16672732afbf4c3f933e67ac677aa1877f6a7657 /gnu/packages/javascript.scm
parent903874328ed5e5ab766e36cee1b1a0989e8b24a9 (diff)
parent2cf8531f360ef390d3ec670cc150b106bab5eff1 (diff)
downloadguix-patches-539bf8f2c071b53834829259bb3fabf0390c5dc6.tar
guix-patches-539bf8f2c071b53834829259bb3fabf0390c5dc6.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/javascript.scm')
-rw-r--r--gnu/packages/javascript.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index eeeec406a8..3a9e88ad08 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -370,6 +371,44 @@ to ES5 without causing run-time errors in older engines. In many cases, this
means that these shams cause many ES5 methods to silently fail.")
(license license:expat)))
+(define-public js-filesaver
+ (package
+ (name "js-filesaver")
+ (version "1.3.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/eligrey/FileSaver.js/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version))
+ (sha256
+ (base32
+ "1rkhfqs5plaj628kzj7qgm5qahy4v7ihygifidqr6g6265mil97h"))))
+ (build-system minify-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-uglification
+ ;; Remove "export" keyword which prevents the file from being
+ ;; uglified by uglify-js. Moreover, that keyword is not present in
+ ;; the minified version of the library some projects are using,
+ ;; e.g.,
+ ;; <https://github.com/jmoenig/Snap--Build-Your-Own-Blocks/blob/master/FileSaver.min.js>
+ (lambda _
+ (substitute* "src/FileSaver.js"
+ (("export ") ""))
+ #t)))))
+ (home-page
+ "https://eligrey.com/blog/saving-generated-files-on-the-client-side/")
+ (synopsis "HTML5 saveAs() FileSaver implementation")
+ (description "@file{FileSaver.js} implements the @code{saveAs()}
+FileSaver interface in browsers that do not natively support it.
+
+@file{FileSaver.js} is the solution to saving files on the
+client-side, and is perfect for webapps that need to generate files,
+or for saving sensitive information that shouldn't be sent to an
+external server.")
+ (license license:expat)))
+
(define-public mujs
(package
(name "mujs")