summaryrefslogtreecommitdiff
path: root/gnu/packages/javascript.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-03 15:54:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-04 11:23:52 +0200
commit3f48403aafc3cd6e50c178fb15b6251a40969c07 (patch)
tree55f7f2648b1b0ae1d58e8b0bdc5f690a1925d021 /gnu/packages/javascript.scm
parent68ffb6c586de4dfd4dd5c972d3481a4243ba8bde (diff)
downloadguix-patches-3f48403aafc3cd6e50c178fb15b6251a40969c07.tar
guix-patches-3f48403aafc3cd6e50c178fb15b6251a40969c07.tar.gz
gnu: Add js-strftime.
* gnu/packages/javascript.scm (js-strftime): New variable.
Diffstat (limited to 'gnu/packages/javascript.scm')
-rw-r--r--gnu/packages/javascript.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index a806cb0745..fdf5224746 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -206,3 +206,26 @@ function that uses recursive descent instead of @code{eval}.
and DAGs in JSON, and to then recover them. This is a capability that is not
provided by ES5. @code{JSONPath} is used to represent the links.")
(license license:public-domain))))
+
+(define-public js-strftime
+ (package
+ (name "js-strftime")
+ (version "0.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/samsonjs/strftime/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1iya43w7y26y2dp9l4d40bhjc4scb5a9mng5ng5c8hsqr82f1375"))))
+ (build-system minify-build-system)
+ (arguments
+ `(#:javascript-files '("strftime.js")))
+ (home-page "https://github.com/samsonjs/strftime")
+ (synopsis "Implementation of strftime to JavaScript")
+ (description "This is an implementation of the @code{strftime} procedure
+for JavaScript. It works in (at least) node.js and browsers. It supports
+localization and timezones. Most standard specifiers from C are supported as
+well as some other extensions from Ruby.")
+ (license license:expat)))