summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-19 15:56:20 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-19 23:45:56 +0100
commitebf8048d1493b734e188cf5a1557002c961de319 (patch)
treebd5e7e9f27fb968e080f55821af2cf731ab8eacc /gnu/packages/java.scm
parent6b66e47052e859e3b36899e5b0a19e2adebde32f (diff)
downloadguix-patches-ebf8048d1493b734e188cf5a1557002c961de319.tar
guix-patches-ebf8048d1493b734e188cf5a1557002c961de319.tar.gz
gnu: javacc: Don't use unstable tarball.
* gnu/packages/java.scm (javacc)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 8a695102e1..9747569009 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2268,19 +2268,20 @@ debugging, etc.")
(package
(inherit javacc-4)
(version "7.0.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/javacc/javacc/"
- "archive/" version ".tar.gz"))
- (file-name (string-append "javacc-" version ".tar.gz"))
- (sha256
- (base32
- "0z7p9irwarc3avlcdyv9bd3zz57m1aawj8dr95wgxzg5z8fki8m6"))
- (modules '((guix build utils)))
- ;; Delete bundled jars.
- (snippet '(begin (for-each delete-file-recursively
- '("bootstrap" "lib"))
- #t))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/javacc/javacc.git")
+ (commit version)))
+ (file-name (git-file-name "javacc" version))
+ (sha256
+ (base32 "18kkak3gda93gr25jrgy6q00g0jr8i24ri2wk4kybz1v234fxx9i"))
+ (modules '((guix build utils)))
+ ;; Delete bundled jars.
+ (snippet '(begin (for-each delete-file-recursively
+ '("bootstrap" "lib"))
+ #t))))
(arguments
`(#:make-flags ; bootstrap from javacc-4
(list (string-append "-Dbootstrap-jar="