summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-07 09:50:51 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-07 09:52:31 +0200
commitd3e22bcc1141cd33dde7017f51058f18d428917c (patch)
treec196f1d756e9fb9d0a38e50658f364d93758db48 /gnu/packages/java.scm
parent4261a9d162f723347981dfc6e72c8938343681a5 (diff)
downloadguix-patches-d3e22bcc1141cd33dde7017f51058f18d428917c.tar
guix-patches-d3e22bcc1141cd33dde7017f51058f18d428917c.tar.gz
gnu: icedtea-7: Support non-Intel systems.
This is a followup to 1b6f99ea538d767099596860017e67755c1ac42f. * gnu/packages/java.scm (icedtea-7)[arguments]: In 'install-libjvm' phase, match armhf and aarch64. [supported-systems]: New field.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 3b7404973a..452180eead 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1377,11 +1377,17 @@ bootstrapping purposes.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((lib-path (string-append (assoc-ref outputs "out")
"/lib/"
+ ;; See 'INSTALL_ARCH_DIR' in
+ ;; 'configure'.
,(match (%current-system)
("i686-linux"
"i386")
("x86_64-linux"
- "amd64")))))
+ "amd64")
+ ("armhf-linux"
+ "arm")
+ ("aarch64-linux"
+ "aarch64")))))
(symlink (string-append lib-path "/server/libjvm.so")
(string-append lib-path "/libjvm.so")))
#t))
@@ -1529,6 +1535,10 @@ bootstrapping purposes.")
(description
"This package provides the Java development kit OpenJDK built with the
IcedTea build harness.")
+
+ ;; 'configure' lists "mips" and "mipsel", but not "mips64el'.
+ (supported-systems (delete "mips64el-linux" %supported-systems))
+
;; IcedTea is released under the GPL2 + Classpath exception, which is the
;; same license as both GNU Classpath and OpenJDK.
(license license:gpl2+))))