summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-25 21:14:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-03-25 21:41:27 +0200
commitc98d7a66cc98b950b48bcfd313dce5d20ecb6bc8 (patch)
treea16cdf881e33b054cd01f7681f2c72c3202e7c47 /gnu/packages/java.scm
parent58d2b13544e3b10fc88df8508f978c341794b6d0 (diff)
downloadguix-patches-c98d7a66cc98b950b48bcfd313dce5d20ecb6bc8.tar
guix-patches-c98d7a66cc98b950b48bcfd313dce5d20ecb6bc8.tar.gz
gnu: classpath-jamvm-wrappers: Use classpath-0.99.
* gnu/packages/java.scm (classpath-jamvm-wrappers): Inherit from classpath-0.99. [native-inputs]: Replace "jamvm-bootstrap" with "jamvm-1-bootstrap"; replace "classpath-on-sablevm" with "classpath-0.99".
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 1ee270b83c..1cc11f88e8 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -544,10 +544,10 @@ the standard javac executable.")))
("libltdl" ,libltdl)
("pkg-config" ,pkg-config)))))
-;; We need this because the tools provided by the latest release of GNU
-;; Classpath don't actually work with sablevm.
+;; We need this because classpath-bootstrap does not provide all of the tools
+;; we need to build classpath-devel.
(define classpath-jamvm-wrappers
- (package (inherit classpath-on-sablevm)
+ (package (inherit classpath-0.99)
(name "classpath-jamvm-wrappers")
(source #f)
(build-system trivial-build-system)
@@ -581,8 +581,8 @@ gnu.classpath.tools.~a.~a $@"
#t))))
(native-inputs
`(("bash" ,bash)
- ("jamvm" ,jamvm-bootstrap)
- ("classpath" ,classpath-on-sablevm)))
+ ("jamvm" ,jamvm-1-bootstrap)
+ ("classpath" ,classpath-0.99)))
(inputs '())
(synopsis "Executables from GNU Classpath")
(description "This package provides wrappers around the tools provided by