summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-13 00:59:31 +0200
committerMarius Bakke <marius@gnu.org>2022-09-13 14:53:08 +0200
commitc463d7ac916d86c4afd50dc5aecf645ff2deeb14 (patch)
tree62d359aa78fcb2c9ee903644c57a19fb611a3698 /gnu/packages/java.scm
parent389b5b5359e82be5e0417fd3505661b1800fca40 (diff)
downloadguix-patches-c463d7ac916d86c4afd50dc5aecf645ff2deeb14.tar
guix-patches-c463d7ac916d86c4afd50dc5aecf645ff2deeb14.tar.gz
gnu: OpenJDK@10: Fix build with newer toolchains.
* gnu/packages/java.scm (openjdk10)[source](patches): Add two patches. [source](snippet): While here, simplify. * gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch, gnu/packages/patches/openjdk-10-hotspot-stack-size.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index fda361a4a6..53216cca9d 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1729,12 +1729,12 @@ new Date();"))
(base32
"0zywq2203b4hx4jms9vbwvjcj1d3k2v3qpx4s33729fkpmid97r4"))
(patches (search-patches
- "openjdk-10-idlj-reproducibility.patch"))
+ "openjdk-10-idlj-reproducibility.patch"
+ "openjdk-10-hotspot-pointer-comparison.patch"
+ "openjdk-10-hotspot-stack-size.patch"))
(modules '((guix build utils)))
(snippet
- `(begin
- (for-each delete-file (find-files "." ".*.(bin|exe|jar)$"))
- #t))))
+ '(for-each delete-file (find-files "." "\\.(bin|exe|jar)$")))))
(arguments
(substitute-keyword-arguments (package-arguments openjdk9)
((#:phases phases)