summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-02 23:00:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-02 23:58:56 +0100
commit345b341919304505c11494724c526e559db3eb68 (patch)
tree447383f50c7007a197bb1dba39ffe2f15a38568c /gnu/packages/java.scm
parent68e71fbb174a680e89f3eb41540d187fdeb780fc (diff)
downloadguix-patches-345b341919304505c11494724c526e559db3eb68.tar
guix-patches-345b341919304505c11494724c526e559db3eb68.tar.gz
gnu: openjdk16: Use MAKE-FILE-WRITABLE.
* gnu/packages/java.scm (openjdk16)[arguments]: Do not shell out to "chmod".
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 8306dbf868..36424ee8b1 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2573,12 +2573,9 @@ new Date();"))
;; The build system copies a few .template files from the
;; source directory into the build directory and then modifies
;; them in-place. So these files have to be writable.
- (for-each
- (lambda (file)
- (invoke "chmod" "u+w" file))
+ (for-each make-file-writable
(find-files "src/java.base/share/classes/jdk/internal/misc/"
- "\\.template$"))
- #t))))))
+ "\\.template$"))))))))
(home-page "https://openjdk.java.net/projects/jdk/16")))
(define-public openjdk17