summaryrefslogtreecommitdiff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-06-01 00:44:22 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-06-22 13:10:38 +0200
commit01706f6e0081674dffa39a49c33e04d48aad5300 (patch)
tree46dd648923cdbe35dc2c549bb90fd010b32a4562 /gnu/packages/java.scm
parent7f902d368de9d5539ae0caf531fe64bca5339c5f (diff)
downloadguix-patches-01706f6e0081674dffa39a49c33e04d48aad5300.tar
guix-patches-01706f6e0081674dffa39a49c33e04d48aad5300.tar.gz
gnu: Add java-jopt-simple-4.
* gnu/packges/java.scm (java-jopt-simple-4): New variable. (java-jopt-simple): Install to maven repository structure.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm32
1 files changed, 30 insertions, 2 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 59f9497ec2..b34e31a612 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017, 2019, 2021 Carlo Zancanaro <carlo@zancanaro.id.au>
-;;; Copyright © 2017-2020 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2017-2021 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2017, 2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -5781,7 +5781,13 @@ The jMock library
(build-system ant-build-system)
(arguments
`(#:tests? #f ; there are no tests
- #:jar-name "jopt-simple.jar"))
+ #:jar-name "jopt-simple.jar"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'create-pom
+ (generate-pom.xml "pom.xml" "net.sf.jopt-simple" "jopt-simple" ,version))
+ (replace 'install
+ (install-from-pom "pom.xml")))))
(home-page "https://pholser.github.io/jopt-simple/")
(synopsis "Java library for parsing command line options")
(description "JOpt Simple is a Java library for parsing command line
@@ -5793,6 +5799,28 @@ retrieval of options and their arguments simple and expressive, without being
overly clever.")
(license license:expat)))
+;; Required by jmh
+(define-public java-jopt-simple-4
+ (package
+ (inherit java-jopt-simple)
+ (version "4.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://repo1.maven.org/maven2/"
+ "net/sf/jopt-simple/jopt-simple/"
+ version "/jopt-simple-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "0ny82zczxkn201ld0b7rps0ifzjhfs8m1ncdmy1f50145ciszkpd"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments java-jopt-simple)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'create-pom
+ (generate-pom.xml "pom.xml" "net.sf.jopt-simple" "jopt-simple"
+ ,version))))))))
+
(define-public java-commons-math3
(package
(name "java-commons-math3")