summaryrefslogtreecommitdiff
path: root/gnu/packages/java-graphics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-19 22:59:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-19 23:21:06 +0100
commit1fb76dce3e2ea62bb0ba8d118a56b4476c953fb4 (patch)
treeea5fb996fb3b46f2c50d4d2d1573e30a690c2590 /gnu/packages/java-graphics.scm
parentedf8152563a898438708ec9b2b17284a9d55d271 (diff)
downloadguix-patches-1fb76dce3e2ea62bb0ba8d118a56b4476c953fb4.tar
guix-patches-1fb76dce3e2ea62bb0ba8d118a56b4476c953fb4.tar.gz
gnu: Add java-piccolo2d-core.
* gnu/packages/java-graphics.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/java-graphics.scm')
-rw-r--r--gnu/packages/java-graphics.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/java-graphics.scm b/gnu/packages/java-graphics.scm
new file mode 100644
index 0000000000..7c1a5f68b4
--- /dev/null
+++ b/gnu/packages/java-graphics.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages java-graphics)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix utils)
+ #:use-module (guix build-system ant)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages java)
+ #:use-module (gnu packages xorg))
+
+(define-public java-piccolo2d-core
+ (package
+ (name "java-piccolo2d-core")
+ (version "3.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/piccolo2d/piccolo2d.java")
+ (commit (string-append "piccolo2d-complete-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1k6gw643k83516lcw04mgac2yi75phdrng44pz9xk6hz066ip21s"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "piccolo2d-core.jar"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "core") #t)))))
+ (inputs
+ `(("java-junit" ,java-junit)))
+ (home-page "http://piccolo2d.org")
+ (synopsis "Structured 2D graphics framework")
+ (description "Piccolo2D is a framework (in the Jazz ZUI tradition) to
+create robust, full-featured graphical applications in Java, with features
+such as zooming and multiple representation. This package provides the core
+libraries.")
+ (license license:bsd-3)))