summaryrefslogtreecommitdiff
path: root/gnu/packages/jami.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/jami.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/jami.scm')
-rw-r--r--gnu/packages/jami.scm78
1 files changed, 37 insertions, 41 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 7c38b17b5e..926cf083a2 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -437,13 +437,13 @@
("webrtc-audio-processing" ,webrtc-audio-processing)
("yaml-cpp" ,yaml-cpp)))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gcc" ,gcc-8) ;charconv requires GCC 8.1+
- ("libtool" ,libtool)
- ("perl" ,perl) ;to generate manpages with pod2man
- ("pkg-config" ,pkg-config)
- ("which" ,which)))
+ (list autoconf
+ automake
+ gcc-8 ;charconv requires GCC 8.1+
+ libtool
+ perl ;to generate manpages with pod2man
+ pkg-config
+ which))
(arguments
`(#:tests? #f ; The tests fail to compile due to missing headers.
#:make-flags '("V=1") ;build verbosely
@@ -472,10 +472,9 @@ protocols, as well as decentralized calling using P2P-DHT.")
(build-system cmake-build-system)
(outputs '("out" "debug"))
(inputs
- `(("libring" ,libring)
- ("network-manager" ,network-manager)))
+ (list libring network-manager))
(propagated-inputs
- `(("qtbase" ,qtbase-5))) ; Qt is included in several installed headers.
+ (list qtbase-5)) ; Qt is included in several installed headers.
(arguments
`(#:tests? #f ; There is no testsuite.
#:configure-flags
@@ -515,25 +514,25 @@ decentralized calling using P2P-DHT.")
(build-system cmake-build-system)
(outputs '("out" "debug"))
(inputs
- `(("clutter" ,clutter)
- ("clutter-gtk" ,clutter-gtk)
- ("gtk+" ,gtk+)
- ("libcanberra" ,libcanberra)
- ("libappindicator" ,libappindicator)
- ("libnotify" ,libnotify)
- ("libringclient" ,libringclient)
- ("network-manager" ,network-manager)
- ("qrencode" ,qrencode)
- ("sqlite" ,sqlite)
- ("webkitgtk" ,webkitgtk)))
+ (list clutter
+ clutter-gtk
+ gtk+
+ libcanberra
+ libappindicator
+ libnotify
+ libringclient
+ network-manager
+ qrencode
+ sqlite
+ webkitgtk))
(native-inputs
`(("pkg-config" ,pkg-config)
("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin"))) ;for glib-compile-resources
(propagated-inputs
- `(("libring" ,libring) ; Contains 'dring', the daemon, which is
- ; automatically started by DBus.
- ("adwaita-icon-theme" ,adwaita-icon-theme)))
+ (list libring ; Contains 'dring', the daemon, which is
+ ; automatically started by DBus.
+ adwaita-icon-theme))
(arguments
`(#:tests? #f ;no test suite
#:imported-modules (,@%cmake-build-system-modules
@@ -584,25 +583,22 @@ decentralized calling using P2P-DHT.")
(lambda _
(chdir "client-qt"))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("qttools" ,qttools)
- ("doxygen" ,doxygen)
- ("graphviz" ,graphviz)))
+ (list pkg-config qttools doxygen graphviz))
(inputs
- `(("libnotify" ,libnotify)
- ("libringclient" ,libringclient)
- ("network-manager" ,network-manager)
- ("qrencode" ,qrencode)
- ("qtsvg" ,qtsvg)
- ("qtwebengine" ,qtwebengine)
- ("qtwebchannel" ,qtwebchannel)
- ("qtmultimedia" ,qtmultimedia)
- ("qtdeclarative" ,qtdeclarative)
- ("qtgraphicaleffects" ,qtgraphicaleffects)
- ("qtquickcontrols" ,qtquickcontrols)
- ("qtquickcontrols2" ,qtquickcontrols2)))
+ (list libnotify
+ libringclient
+ network-manager
+ qrencode
+ qtsvg
+ qtwebengine
+ qtwebchannel
+ qtmultimedia
+ qtdeclarative
+ qtgraphicaleffects
+ qtquickcontrols
+ qtquickcontrols2))
(propagated-inputs
- `(("libring" ,libring))) ;for dring
+ (list libring)) ;for dring
(home-page "https://jami.net")
(synopsis "Qt Jami client")
(description "This package provides the Jami Qt client. Jami is a secure