summaryrefslogtreecommitdiff
path: root/gnu/packages/jami.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-09 23:20:18 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-10 00:55:18 -0400
commit59134f1e02dbde6d82e6204b51ca49347b8037d9 (patch)
treebcc45320b3fc97055602978d70fc49339a4f533b /gnu/packages/jami.scm
parentfed28a9632ba69225151757e44a5d70e9b0652a2 (diff)
downloadguix-patches-59134f1e02dbde6d82e6204b51ca49347b8037d9.tar
guix-patches-59134f1e02dbde6d82e6204b51ca49347b8037d9.tar.gz
gnu: jami-qt: Remove the custom wrap phase.
Commit 06eb21856f made it necessary, since it is now handled by the Qt build system itself. * gnu/packages/jami.scm (jami-qt)[phases]{wrap}: Remove phase.
Diffstat (limited to 'gnu/packages/jami.scm')
-rw-r--r--gnu/packages/jami.scm26
1 files changed, 7 insertions, 19 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 42b15cee9b..0adc3ed81e 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -585,25 +585,13 @@ decentralized calling using P2P-DHT.")
(outputs '("out" "debug"))
(arguments
`(#:tests? #f ;no test suite
- #:phases
- (modify-phases %standard-phases
- ;; TODO: Uncomment after switching back to the tarball source.
- ;; (add-after 'unpack 'change-directory
- ;; (lambda _
- ;; (chdir "client-qt")))
- (add-after 'install 'wrap
- ;; The program fails to find the QtWebEngineProcess program, so we
- ;; set QTWEBENGINEPROCESS_PATH to help it.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin"))
- (qtwebengineprocess (string-append
- (assoc-ref inputs "qtwebengine")
- "/lib/qt5/libexec/QtWebEngineProcess")))
- (for-each (lambda (program)
- (wrap-program program
- `("QTWEBENGINEPROCESS_PATH" =
- (,qtwebengineprocess))))
- (find-files bin ".*"))))))))
+ ;; TODO: Uncomment after switching back to the tarball source.
+ ;; #:phases
+ ;; (modify-phases %standard-phases
+ ;; (add-after 'unpack 'change-directory
+ ;; (lambda _
+ ;; (chdir "client-qt"))))
+ ))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)