summaryrefslogtreecommitdiff
path: root/gnu/packages/iso-codes.scm
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-10-15 03:28:59 +0200
committerCyril Roelandt <tipecaml@gmail.com>2013-12-15 23:39:43 +0100
commit2748062080ded4568b79fcfc2f0f37526bfaa80c (patch)
treed4df0b821865fce2f9567e15a5450b871387f836 /gnu/packages/iso-codes.scm
parent7a8605ceb54f8c91d968ad6e6e4d247db776d03e (diff)
downloadguix-patches-2748062080ded4568b79fcfc2f0f37526bfaa80c.tar
guix-patches-2748062080ded4568b79fcfc2f0f37526bfaa80c.tar.gz
gnu: Add iso-codes.
* gnu/packages/iso-codes.scm: New file. * gnu-system.am: Add it.
Diffstat (limited to 'gnu/packages/iso-codes.scm')
-rw-r--r--gnu/packages/iso-codes.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/iso-codes.scm b/gnu/packages/iso-codes.scm
new file mode 100644
index 0000000000..e1424b81ef
--- /dev/null
+++ b/gnu/packages/iso-codes.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages iso-codes)
+ #:use-module ((guix licenses) #:select (gpl2+))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages python))
+
+(define-public iso-codes
+ (package
+ (name "iso-codes")
+ (version "3.47")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://pkg-isocodes.alioth.debian.org/downloads/iso-codes-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1ka2rrnfwbydklpx9p1cw74z03v5h0df3pjplq5ic689jngcv6a8"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("gettext" ,gnu-gettext)
+ ("perl" ,perl)
+ ("python-2" ,python-2)))
+ (home-page "http://pkg-isocodes.alioth.debian.org/")
+ (synopsis "Various ISO standards")
+ (description
+ "This package provides lists of various ISO standards (e.g. country,
+language, language scripts, and currency names) in one place, rather
+than repeated in many programs throughout the system.
+
+Currently there are lists of languages and countries embedded in
+several different programs, which leads to dozens of lists of
+200 languages, translated into more than 30 languages... not
+very efficient.
+
+With this package, we create a single \"gettext domain\" for every
+supported ISO standard which contains the translations of
+that domain. It is easy for a programmer to re-use those
+translations instead of maintaining their own translation
+infrastructure. Moreover, the programmer does not need to follow
+changes in the ISO standard and will not work with outdated
+information.")
+ ; Some bits use the lgpl2
+ (license gpl2+)))